SteamVR Not Ready after registering the driver

Homepage Forums How-to and troubleshooting SteamVR Not Ready after registering the driver

Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #3922
    SiegeEngineSiegeEngine
    Participant

    Hey all,

    Every time I try to register the driver to SteamVr and restart it always say Not Ready. If I un register it then its fine.

    Any ideas?

    #3923
    SiegeEngineSiegeEngine
    Participant

    *UPDATE*

    Ive managed to fix the ‘Not Ready’ error by switching over to the openvr-beta. However now driver4vr will not install properly to SteamVR. I’ve registered it multiple times with no result.

    #3931
    Bla BlablaGreg Driver
    Keymaster

    hi.
    it happens very occasionally and unfortunately this can be issue with SteamVR as well.
    what is your config and what do you try to accomplish? body tracking?

    #3958
    SiegeEngineSiegeEngine
    Participant

    I’m using an oculus set up with a Kinect 360. I’m trying to use body tracking

    #3960
    SiegeEngineSiegeEngine
    Participant

    .

    Attachments:
    You must be logged in to view attached files.
    #3966
    Bla BlablaGreg Driver
    Keymaster

    can you please:
    1. uninstall driver.
    2. install driver
    if does not start automatically, please start it explicitely from start menu. it will appear as you press windows button and start typing Drvier4VR.
    then please send me logs from application folder. (Program Files (0x86)/Driver4VR)

    they are in logs subfolder.

    thanks.

    #3994
    SiegeEngineSiegeEngine
    Participant

    Here is the log

    Attachments:
    You must be logged in to view attached files.
    #4010
    SiegeEngineSiegeEngine
    Participant

    Bump

    #4014
    Bla BlablaGreg Driver
    Keymaster

    this might be missing.

    #4015
    SiegeEngineSiegeEngine
    Participant

    Upon trying to install it the set-up failed due to a previous version already installed. I have up to 2017

    #4017
    SiegeEngineSiegeEngine
    Participant

    Along with any other solution you want to give, I can try installing it manually if that could work. However I will need those steps.

    #4040
    SiegeEngineSiegeEngine
    Participant

    bump.

    #4107
    Bla BlablaGreg Driver
    Keymaster

    can you try this. 64 bit version.
    after you open this tool, drag driver_driver4vr.dll usually from installation folder\lib\drivers\driver4vr\bin\win64

    then choose file->save as and send me file.

    #4165
    Bla BlablaGreg Driver
    Keymaster

    ok. i think you are on beta inputemulator of SteamVR. is that the case?

    #4173
    SiegeEngineSiegeEngine
    Participant

    Yes

    #4174
    SiegeEngineSiegeEngine
    Participant

    When I take Steam VR out of Beta it says not ready and missing key components

    #4175
    SiegeEngineSiegeEngine
    Participant

    I can only see my set-up in the openvr temp beta

    #4209
    Bla BlablaGreg Driver
    Keymaster

    why is that case? do you use psmoveservice ?
    sorry, i don’t support this steamvr beta.

    • This reply was modified 2 years, 8 months ago by Bla BlablaGreg Driver.
    #4219
    SiegeEngineSiegeEngine
    Participant

    I’m using full oculus with attempt at a 360 kinect

    #4233
    SiegeEngineSiegeEngine
    Participant

    I’ve managed to get regular non-beta Steam VR working however when I register the driver it throws me the 301 error “Missing Key Component” and when I unregistered the driver it works again

    #4753
    Sherman ChenSherman Chen
    Participant

    So, did anyone find the solution to this problem? I am also experiencing the 301 error “Missing Key Component” and when I unregistered the driver it works again and having the Unable to connect to SteamVR. Error: IPC_ConnectFailedAfterMultipleAttempts error

    #4758
    AikatsuyuriAikatsuyuri
    Participant

    You could try running the VRstartup in;

    C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64.

    When I try launching SteamVR in the actual client, it never works for me so I just have a shortcut to this.

    #4761
    Bla BlablaGreg Driver
    Keymaster

    can you please send me logs as described here?

    when driver is installed of course.

    i need verify first if there is anything unusual in your configuration.

    unfortunately this is very uncommon problem, can be also on side of other driver.

    then I can provide test build where I will make some changes so you can try it out.

Viewing 23 posts - 1 through 23 (of 23 total)
  • You must be logged in to reply to this topic.