Xbox controller clash

Homepage Forums How-to and troubleshooting Xbox controller clash

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #14699
    Thomas Anthony PedersennufanDK
    Participant

    Hi Greg.

    I’ve been fiddling with your software a few days now, and I’m really impressed. It works great with the Kinect, but of course the input is a bit off sometimes, and I miss the additional buttons that a controller has. So I tried with my Xbox controller, but I think there might be a clash with SteamVR also recognizing the controller.
    For example, I think I can set it up correctly, as I use the right stick it seems to be responding briefly (showing the pointer laser of the controller in-game), but when the stick reaches the maximum (e.g. all the way to the right) the game display jumps to the right. I’ve noticed that the xbox controllers has this functionality when Driver4VR is not running, so I’m guessing it is some SteamVR functionality, but is there any work around to this?

    Also, on another note: when I preview my controller in the “Tracker Manager”, the values are updating as I use the sticks, but the red square does not actually move around (as in the videos on Youtube). It just “shakes” and seems to be constantly forced back to zero. This might be unrelated and totally benign, but I just wanted to let you know, in case you have any help or feedback for this as well?

    #14717
    Bla BlablaGreg Driver
    Keymaster

    can you check if shaking of red rectangle is not related to your hand?
    because when you use kinect + xbox controller then xbox controller is not really used for hand tracking. i realize that this might be confusing.
    if you select virtual trackers for hand tracking then it will respond only to controller.

    #14739
    Thomas Anthony PedersennufanDK
    Participant

    I’m sorry, I don’t think I was quite clear in my post.
    I’m testing a setup with Vridge and GearVR together with Driver4VR. For the testing of the controller I turned off the kinect tracking.
    I’ve found two answers to my post, but a new question arose.
    The reason the red square was not working was apparently because Vridge adds another Virtual Gamepad, that was showing up, and though linked to the Xbox controller, it did not translate comletely. Once I chose the “right” gamepad, I could move the red square around (at least with one stick). Now to my question regarding the clash with SteamVR, I’m a bit unsure if it was actually a problem or not, since I found the problem with the Vridge virtual controller. However, I did manage to find, that SteamVR does have bindings to the gamepad, and I do think that was the problem. In the SteamVR settings, I found that I could remove all bindings to the controller (per app, but since I’m just testing with SteamVR Home right now, it was easy), and that solved the conflicting bindings.

    However, now another issue has come up. I can get the Vive controllers to be controlled by my gamepad, but they don’t show up on the screen. The “laser” shows up, if I press the trigger, and the variety of tools comes up when pressing the shoulder, but when nothing is pressed, they don’t show up. This is problematic, as they often tend to drift outside my viewfinder, and it gets a bit difficult to locate them 🙂

    • This reply was modified 7 months ago by Thomas Anthony PedersennufanDK.
Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.