Kinect 2.0 restart loop, no frames

Homepage Forums How-to and troubleshooting Kinect 2.0 restart loop, no frames

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #38629
    Joseph SidhuVR Boy
    Participant

    Hi all,

    so I’ve managed to get my full body working with this very same pc last year, and it worked well. I’m still using windows 1903 that I was when it worked last year, and there hasn’t been a change in components.
    I tried to set up my kinect tracking earlier this year, except the tracking was horrible and unusable so I gave up. Fast forward to now; I decide to give it another go because I’ve been wanting to use full body tracking.

    Now my kinect is constantly connecting and disconnecting. I’ve had this issue before but I was always able to fix it, it used to be that I had to enable mu kinect mic but, that doesn’t work anymore. I’ve tried uninstalling all kinect software, installing just the runtime and installing runtime with the dev SDK2.0, the problem still persisted.
    If I time it right and click start driver4VR it will start like it works but, the kinect has 0 frames while the Driver4VR fps is solid at 61-62 FPS. Kinect studio is unable to receive any frames from the kinect as well.

    I’ve tried restarting my PC about 40 times today and that didn’t change anything or get me further. The 3 services KinectMonitor.exe, KinectService.exe, and KStudioHostService.exe are running fine in the background and don’t restart themselves. Not sure what’s going on here but, I’ve tried everything I could find on the internet to try to fix this issue without any success

    Attachments:
    You must be logged in to view attached files.
    #38634
    Joseph SidhuVR Boy
    Participant

    Another thing to note is the Kinect itself isn’t picking up any audio through the microphone, seems like something is being blocked. The KinectService.exe also says it last accessed the microphone in August 2020 and it’s currently November 2020 so that’s odd

    #38638
    Joseph SidhuVR Boy
    Participant

    Update: I managed to get tracking working, what I needed to do for a fix was quite different from what I’ve seen other do. I uninstalled the Kinect software and I searched “Kinect” in my C drive then deleted everything except for kinect plugins in games like VRChat and the installers. I then shutdown my pc and unplugged my Kinect from the device itself, not the USB or power bar, took it outside and gave it a good clean with compressed air. Barely any dust came out so I’m not sure if that or heat was an issue to begin with, nor am I sure which process if not both fixed my issue. Thought I’d put this info out there for anyone dealing with the particularly odd situation I was faced with.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.