head position tracking move to wrong way ! in SteamVR

Homepage Forums How-to and troubleshooting head position tracking move to wrong way ! in SteamVR

Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #981
    karostkarost
    Participant

    Please help!
    Head tracking move to wrong way in steamVR
    ——————————————
    when move head tracking forward but in VR move to the left
    when move head tracking backwards but in VR move to the right
    when move head tracking to left in VR move backwards
    when move head tracking to right in VR move forwards

    head tracking up-down is working collect in steamVR

    Hardware :
    1) pimax4k with 4 eyeps3 cam and one ping pong for position tracking
    2) 1x PSmove controller ( for setting )

    Software : driver4VR(G) , SteamVR ,PSMoveService,FreePie,PSMoveFreepieBridge

    Process: I use this guide

    Testing in PSMoveConfigTool:Test Tracking Pose is working collect!
    head tracking and VR move to same way.

    ps. I use Pimax for play Elite Dangerous and happy now. I need Head position tracking feature for play IL2 in VR because BF 109 and FW 190 gun sign is locate on the right eye not center 😛

    #982
    JonnyJonny
    Participant

    Not sure, but I think that problem is caused by Piplay. Make sure your psmove service setup and SteamVR Room setup both point to the same direction. Then in Piplay face that same direction and click recenter. That fixed it for me.

    #983
    CReDoCReDo
    Participant

    Centering in piplay and the problem will be lost

    #984
    Bla BlablaGreg Driver
    Keymaster

    @Jonny, @CReDo
    thanks for support !


    @karost
    if problem still exist let us know.

    Greg

    #985
    karost@hotmail.comkarost@hotmail.com
    Participant

    Thank you to @jonny, @credo and @Greg

    I think I may miss some point

    1) I did not select+start to align the HMD and PSMove tracking spaces when green intstructional overlay asking me to do.

    2) I did not try Orientation Re-centering by point the controller down the forward direction of the calibration mat (the -Z direction) and hold the select button

    3) I miss one process to setting Comupte Tracker Poses in Calibration Mat by put pscontrller to +x+z,-x+z,cener,-x-z,+x-z ,but I did not put my Pimax on HDM frame when program said “Set the HDM at the tracking origin”

    I will try this above after working time and update here.

    😛

    #987
    CReDoCReDo
    Participant

    The start and select for controllers are not needed since it causes problems with the position of controllers in the space. I recommend that you do not use this function.
    I use only the select for calibrating the direction of the controllers and centering in the piplay.

    • This reply was modified 3 years ago by CReDoCReDo.
    #989
    karostkarost
    Participant

    ok I got solution for my case
    1) I re-compute Tracker Poses Using HMD with CalibrationMat.pdf
    2) BEFORE open steamVR I put my Pimax heading foward on the center position ( my chair )
    3) then open steamVR+driver4vr and it working,the head traking and VR moving in the same way 🙂

    it look no reason but it work for me 😛

    Thank you to every one for help me.

    • This reply was modified 3 years ago by karostkarost.
    • This reply was modified 3 years ago by karostkarost.
    #1039
    sir_unlocksir_unlock
    Participant

    Hi Greg,
    first thanks for you work and effort.
    I have the same problem, the tracking is completely reversed. Since it is an issue with the different hmd drivers, is it possible to add a reverse tick box for all the coordinates the kinect can measure(+x = x, +y = -y and so on? after that everything should be fine us, who have that reverse problem.

    Cheers

    #1048
    Bla BlablaGreg Driver
    Keymaster

    there is parameter ‘Angle correction’
    this basically changes rotation between kinect and steamvr. from your description it seems like you need set it to 180 degree, if not please try also different values.
    after changing angle u usually must calibrate steamvr.

    #1058
    karostkarost
    Participant

    I come to update some info that I found in my Pimax.
    Some time my default Pimax direction point to 180 degree backward.
    So I have to click at Pimax’s Recenter one time BEFORE open steamVR+Driver4VR

    Hope this info may help someone who face the same problem. 🙂

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.