Cant get it to sync with psmoveservice properly

Homepage Forums Bugs Cant get it to sync with psmoveservice properly

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #508
    oldmanbluntzoldmanbluntz
    Participant

    Ever since your recent update this is all broken for me. I was using the old version as a head tracker only, and it worked fine tracking me around the room with my psmove setup. The controllers stayed near me as I moved around. So, psmove was just tracking my controllers, and the Kinect One was being used with driver4vr as just a head tracker, and I’m using riftcat with my phone for the headset. I don’t require body tracking like legs and that extra stuff. I just want to use it as a head tracker as its more precise that the lit up pingpong on my head with the playstation cameras.

    What did you change in your update, because since then, no matter what I try, how many calibrations I do with the psmoveservice or with driver4vr, I cannot get the controllers to come close to me. The Kinect registers as being right in the middle of my psmove cameras, not off set like it is, so that makes my headset stay constantly about 8 feet behind my controllers. I cannot get it to sync up correctly anymore. I have been tearing my head out for 3 days now trying to figure what I have changed or done wrong, and it’s my conclusion that I have done nothing wrong. it was something in the update. Is there any way I can get a copy of the old version of driver4vr so I can test my hypothesis further, as this is really pissing me off. I paid for this software because it worked for me the way I wanted. Now, it does not work that way anymore. It’s frustrating.

    • This topic was modified 3 years, 2 months ago by oldmanbluntzoldmanbluntz.
    #510
    oldmanbluntzoldmanbluntz
    Participant

    Okay. I found the problem. I was trying one of the other tweaks, the disabling of the start select psmove calibration gesture, and manually setting the offset in the steamvr.vrsettings file. This does not sork when you are using the Kinect as a headtracker. It will not allow you to calibrate the controller position to the psmove controllers tracked by the psmove service.

    #514
    Bla BlablaGreg Driver
    Keymaster

    glad it worked. in case of problem always welcome on forum 🙂

    #522
    oldmanbluntzoldmanbluntz
    Participant

    Well, it is sort of working. The psmove_extend_z switch in the steamvr.vrsettings file is quite nice, as it hard codes the position of the controllers in relation to the headset. It fixes a lot of the rotation issues with the controllers when you go around in a circle. There seems to be something in Driver4VR that may be overriding the settings.

    If possible, would there be a way for you to add a way to change the position of the Kinect in relation to the camera positions in the software. I have done a lot of testing to find out what my issue was, and this is the conclusion I have come to. Essentially, if there is a way to add a manual way to set the distance of the Kinect to the center of the play area, that would fix this issue.

    The command I’m talking about in the steamvr.vrsettings file has only been implemented in a custom build of the most recent psmoveservice and the psmovesteamvrbridge projects, so it’s not a mainstream issue. It just had me banging my head of the wall. Thank you for your time.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.