Camera position too far away

Homepage Forums How-to and troubleshooting Camera position too far away

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #432
    darkvulpinedarkvulpine
    Participant

    Kinect 360, SDK 1.8 and 2.0 (tried both)
    Oculus Rift w/touch controllers
    6’x6′ play area to work with
    Windows 10

    Activating Driver4VR causes my camera to move far behind my actual play area.
    I can see my leg trackers on my person in the right position to my perspective, but my Touch controllers remain in the play area which is too far away, like… 5-7 feet away.

    I’ve tried calibrating several times, and tried to move the Kinect to different locations, but the only one that tracks is directly in front.

    #441
    Bla BlablaGreg Driver
    Keymaster

    i know the issue. will provide fix on Monday as also work on few other.

    #475
    runierunie
    Participant

    Any update on this? same issue happens to me

    #484
    Bla BlablaGreg Driver
    Keymaster

    can you please confirm if you have first option to provide head position set to OFF?

    #490
    darkvulpinedarkvulpine
    Participant

    I can’t even turn the option on. It’s greyed out

    I have the leap moron off, and body tracking on

    #496
    Bla BlablaGreg Driver
    Keymaster

    when you start launch and it will connect to steamvr all options are available. but when you press button start driver4vr they will grey out.
    so any change you can do before starting driver4vr.
    pleas confirm if you can set head trackng to ‘off – i have my own head tracking’.

    Greg

    #504
    darkvulpinedarkvulpine
    Participant

    OKay yea, I got it working now, thanks alot!

    #506
    oldmanbluntzoldmanbluntz
    Participant

    And can you share how you got it working for the rest of us? It would be greatly appreciated to the rest of the community for those of us who are still encountering this issue.

    #4951
    SokkzTheClownSokkzTheClown
    Participant

    Bump. I’m having the same issue and have not found a fix.

    Using Oculus Rift, and XboxOne Kinect, SDK 2.0

    #4955
    TheJaegerTheJaeger
    Participant

    To add to this, I have been experiencing the same problem with PS Move Service. I was suffering from the elliptical orbit issue in PS Move, so I applied the following fix in steamvr.vrsettings:

       "psmove_settings" : {
          "disable_alignment_gesture" : true,
          "psmove_extend_y" : 0.20000000298023224,
          "psmove_extend_z" : 0

    While this fixes the elliptical orbit issue, it introduces a second one where Driver4VR moves the position of the head way behind the play zone. See picture (Capture.jpg) for example, where the controllers are being tracked perfectly in the chaperone, but head is outside. Without the elliptical orbit fix, everything works fine.

    A suitable fix was mentioned by cretkensigh here, where he mentioned adding an option to apply head offset in X,Y and Z relative to play area or controller.

    I have no idea why this occurs in the first place, but it has something to do with the removal of calibration of head and controllers within PS move service. This shouldn’t be the case though as controller offset positions via “psmove_extend_y” and “psmove_extend_y” are clearly defined. There is definitely some error in reporting of head position to Steam VR, that follows after applying elliptical orbit fix or as others have reported. This whole situation completely renders D4VR unusable.

    On the positive side, everything from my controllers to head are being tracked perfectly. Once this head positioning is sorted out, it will be a good Vive substitute.

    EDIT: Also another thing I’d like to add is that when Steam VR is run with D4VR off, the PS move controllers track pretty well. When I turn D4VR back on, the above position problem arises. When I turn it off again, the position problem disappears, but then one of my PS move controllers turns into a head tracker. The problem could be that when D4VR starts, it creates a new virtual head tracker controller that doesn’t properly define position of head in relation to controllers.

    • This reply was modified 2 years, 6 months ago by TheJaegerTheJaeger.
    Attachments:
    You must be logged in to view attached files.
    #4988
    Bla BlablaGreg Driver
    Keymaster

    hi.
    the problem was originally related to specific version of driver to enable head tracking. you should ensure that head tracking is off when using oculus.
    please let me know if that solves the problem.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.