binding joycons to driver4vr

Homepage Forums Bugs binding joycons to driver4vr

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #1778
    yeoldecootyeoldecoot
    Participant

    So I’ve been working on getting the input for the Vive controller to be handled by switch Joycons and the tracking being done by my leap motion controller but when I go to map buttons it says i didn’t select a controller and my settings will not be saved. When I go to device manager and try to bind them I can bind everything but the menu+rotation and if I do it stops taking input. Please help

    #1781
    yeoldecootyeoldecoot
    Participant

    where is the save button here

    Attachments:
    You must be logged in to view attached files.
    #1797
    darkagnadarkagna
    Participant

    i have the exact same problem. except ive tried all different types of controllers…… the way to get it to work is to click the controller d4vr- left / right and then click button mapping next to leap motion drop down. although ive run into the issue where sometimes they work, but dont do what i want them to do, but rarely, and unrepeatable, most just dont work at all….. but this way in the config it adds the device, the axis or button, the controller d4vr left or right. so it appears like its all bound. i seriously need some help with this as well, ive been trying for nearly a week.

    #1799
    yeoldecootyeoldecoot
    Participant

    so i got it to work kind of my hands show up as steam controllers not vive controllers any ideas?

    #1808
    darkagnadarkagna
    Participant

    same deal here, even with the psuedo-vive mode on in the 3.1 update, its still steam controllers in anything besides steamvr home. and did you get the buttons to work ingame, or the mapping? if you got the buttons functioning, could you share your config (C:\Program Files (x86)\Steam\config\steamvr.vrsettings). because i can get the mapping to work, i just cant get the buttons to actually do anything.

    #1817
    Bla BlablaGreg Driver
    Keymaster

    hi.
    steam controllers is bug but it is not related to buttons if they work or not.

    It is very interesting idea to use switch Joycons 🙂 they are handy.

    If you don’t mind to take app like AntiMicro and see if all buttons are visible in the tool once you press.

    Greg

    #1856
    yeoldecootyeoldecoot
    Participant

    well i got the buttons to work and i dont know how to acess to the tester in antimicro working will continue though.
    When i try to play a game like taco face(great game btw) all my leap is controlling odd like left on the right right controller on the left.

    #1862
    Bla BlablaGreg Driver
    Keymaster

    you just install AntiMicro and it will detect your controllers and when you press button it will highlight button. there is nothing to configure.

    i did this kind of overlap by purpose to allow holding 2 controllers in one line with eyes like for aiming or shooting with bow. you can disable it in leap settings. without this option you cannot aim cause one hand will be hidden by the other.

    greg

    #2173
    yeoldecootyeoldecoot
    Participant

    sorry about the long delay i’ve been busy so anti micro only really detects 1 of my controllers also what do you mean leap settings like the controller settings next to leap motion as a hand controller or am i missing something(and if so where in the controller settings is the toggle)

    #2201
    Bla BlablaGreg Driver
    Keymaster

    that means 2nd is not compatibile or broken.
    yes. settings next to leap motion you can reduce overlap.

    #2851
    Bla BlablaGreg Driver
    Keymaster

    hi.
    i got them working including rotation, joystick.
    seems pretty cool. anyone would like try ?

    #2894
    el-bohnoel-bohno
    Participant

    Yes please, give us a link 😉

    #2899
    Bla BlablaGreg Driver
    Keymaster

    https://drive.google.com/file/d/1nPM1SA95Wu66QFgY2F343lu3moFUOgCa/view?usp=sharing

    you need pair them first.
    then go to joycon tab in device manager and turn it on.
    then start driver4vr.
    they should be detected. you reset yaw position by home/capture button.

    greg

    #2921
    PodPod
    Participant

    Ooh. I’ll try this tonight.
    How do they compare to a psmove? Is the rotation as accurate? Is there any downside? (it’s perfect for me as I have a pair of joycon but only 1 psmove)

    Paul

    #2942
    Bla BlablaGreg Driver
    Keymaster

    i have not tested it too much yet. but seems very reliable.
    in settings you will find out what current bidning is.

    #3013
    PodPod
    Participant

    (Tested on the rotation around player build you uploaded)

    I tried a joy con with this build. I paired my left joycon before I started everything up and it correctly identified it was my left joycon in the driver4vr controller device manager. However the configure button did nothing. Nevertheless I assigned it to the left hand and in game it both failed to rotate my left hand/wand and none of the buttons did anything.

    Cheers

    Paul

    P.s Didn’t occur to me at the time but might it only work if both joycon are assigned?

    #3074
    PodPod
    Participant

    Turned out my bluetooth was at fault (I think). Updated drivers and now the joycon is working!

    Cheers

    #3077
    Bla BlablaGreg Driver
    Keymaster

    Great 🙂
    They are quite cool I must say. So many buttons 🙂

    #3091
    PodPod
    Participant

    Oh, I should say that the configuration button still does nothing when I click it in version 3.8

    Does the page it should open have the same options as the psmove? I.e assign rotation to a button and a selection for the angle on each press?

    Cheers

    Pod

    #3095
    Bla BlablaGreg Driver
    Keymaster

    i will update it next version. now you should have full set of buttons mapped to steamvr

    #3096
    PodPod
    Participant

    Cool cheers

    #15252
    karen bothamHazzatron75
    Participant

    where is device manager in 5.2.10.2??

Viewing 22 posts - 1 through 22 (of 22 total)
  • You must be logged in to reply to this topic.