Significant delay ps move service

Homepage Forums How-to and troubleshooting Significant delay ps move service

Viewing 25 posts - 1 through 25 (of 25 total)
  • Author
    Posts
  • #1433
    absoluticrousabsoluticrous
    Participant

    Hi, I’m using kinect Xbox one with move controllers on riftcat/vridge. I’m getting a 3-4 second delay between button presses and controller rotation before any registers on my computer. For what it’s worth, I’ve been using ps move service (steamvr bridge version) on it’s own for a few months and never encountered this. I’ve also used it with other kinect tracking services without this issue.

    #1445
    Bla BlablaGreg Driver
    Keymaster

    can you check latest beta if this is still the case?

    #1468
    absoluticrousabsoluticrous
    Participant

    I’ve done a fresh install of all VR components (except Kinect drivers) and used the latest Beta and I’m still getting the delay. I’ve also tried a different bluetooth adapter (though same bluetooth stack). I’ve tried doing only hand tracking. I’ve tried running Driver4VR and PSMoveService as administrator. I’ve tried running both Driver4VR and PSMoveService processes at high priority.

    The delay does occur in device manager preview, but ONLY when SteamVR is running. It does not occur in PSMoveService Config tool.

    • This reply was modified 2 years, 11 months ago by absoluticrousabsoluticrous.
    #1469
    Bla BlablaGreg Driver
    Keymaster

    can you open Preview in Device Manager and tell if delay is also ono this preview or in SteamVR only ?

    #1472
    absoluticrousabsoluticrous
    Participant

    Sorry, I edited my previous post with a reply.

    #1475
    Bla BlablaGreg Driver
    Keymaster

    so I guess next question is how your CPU is feeling ?

    #1476
    Bla BlablaGreg Driver
    Keymaster

    you can turn off head/hand and also if you have body tracking then driver4vr will update only ps move controller. we will see if this is problem of cpu.

    #1478
    absoluticrousabsoluticrous
    Participant

    My CPU is intel core i7-4790K @ 4Ghz with 16GB RAM
    With everything running it is at 20-30% usage according to task manager.

    Attachments:
    You must be logged in to view attached files.
    #1483
    absoluticrousabsoluticrous
    Participant

    Okay, I tried with all tracking off and it still has the delay.

    #1485
    Bla BlablaGreg Driver
    Keymaster

    that basically mean that if you start ps move service and then separately:
    1. run ps move config tool – no delay
    2. run device manager + preview with steamvr – delay
    3. run device manager + preview but close steamvr – no delay.

    you don’t have installed psmoveserice-steamvr bridge

    delay is only on keypress but not on position or orientaiton.

    yes ?

    #1486
    absoluticrousabsoluticrous
    Participant

    Correct, the delay only occurs when steamvr is running and it affects the preview and steamvr, but not device manager/ps move config tool.

    I did have psmoveservice steam bridge installed, but I uninstalled it. I also uninstalled steamvr and deleted all config files and reinstalled fresh.

    The delay is all input to the move controllers. Rotation, buttons, etc. The hand position from the kinect has no delay.

    #1487
    Bla BlablaGreg Driver
    Keymaster

    ok. so we need clarifiaiton here.
    by preview you mean steamvr headset mirror?

    and Driver4VR window that shows orientation and buttons you call it simply device manager. yes?

    that means there are no delay either on psmove config or driver4vr device manager.

    only in steamvr either in preview on in headset. yes?

    #1493
    absoluticrousabsoluticrous
    Participant

    No, the delay is the “preview” window in Driver4VR where you can see button presses and orientation. And everywhere in steamvr, preview/headset/mirror window whatever.

    There is no delay in ps move service config. Let’s forget about “device manager” as that terminology is causing confusion.

    #1507
    absoluticrousabsoluticrous
    Participant

    Here’s my logs. The Driver4VR log doesn’t seem to be updating after a few days ago. Not sure what’s going on.

    Attachments:
    You must be logged in to view attached files.
    #1509
    Bla BlablaGreg Driver
    Keymaster

    some logs are not attached. can you change extension to txt ?
    also there was situaiton that driver log was empty but it was few betas ago. did install recent on e?

    #1512
    absoluticrousabsoluticrous
    Participant

    Ok, here are the missing files.

    Yes, I am using the latest beta as far as I know. I downloaded it yesterday.

    Attachments:
    You must be logged in to view attached files.
    #1515
    Bla BlablaGreg Driver
    Keymaster

    let me recap once more:
    – delay in preview. just driver4vr running but all options are off.
    – no delay in ps move config tool.

    can you do one more thing… basically kill vrserver in task manager so driver4vr will keep on running and see if that will change anything ?
    i think next thing will be simple test app that will have output from ps move in dummy app…

    #1516
    absoluticrousabsoluticrous
    Participant

    Hey, great news! The delay is gone now. First I uninstalled all VR components
    -Kinect
    -SteamVR
    -Driver4VR
    -PSMoveService

    Next I removed all registry entries referencing Driver4VR and PSMoveService, and a few other entries referencing FreePie, Immotion and other software I’ve used with Kinect/PSMove.

    I then reinstalled everything including re-downloading the Driver4VR beta and installing the latest version.

    Sorry I couldn’t give you move straightforward solution, but thanks for all your help!

    #1517
    absoluticrousabsoluticrous
    Participant

    Ahh! Nevermind. It came back. I just restarted steam and the delay is back.

    #1518
    absoluticrousabsoluticrous
    Participant

    Ok, killed vrserver and the delay was still there.

    #1519
    absoluticrousabsoluticrous
    Participant

    Ok, I have another potential solution, it is working consistently. I’ve been able to start SteamVR with no delay 5 times or so using this method. If I start PSMoveService BEFORE running Driver4VR and Steam, there is no delay. If I let Driver4VR start the PSMoveService after hitting the “Start Driver4VR” button then I will get the delay.

    #1523
    absoluticrousabsoluticrous
    Participant

    Just want to say I’m still able to use Driver4VR with NO delay using this method after many tries. Works great for the most part. Just need to tweak the ps move controller orientation a little for shooters to get a perfect alignment

    #1673
    deromaxderomax
    Participant

    Thanks a lot for this fix!

    #1674
    Bla BlablaGreg Driver
    Keymaster

    hi,
    i made MS Move settings window in device manager.
    i described layout of buttons clearly. also there are options to:
    1. treat ps move button as press instead of touch
    2. rotation buttons and options to make 90 or 180 degree.

    i also make automatic changes to ps move service settings so you don’t need any more change them manually.

    for rotation to work well you nee calibrate front of room setup in direction of kinect.

    https://drive.google.com/file/d/1277BJ8Kv3GV-EEbBU4kOi6BQLLg_QTlY/view?usp=sharing

    • This reply was modified 2 years, 11 months ago by Bla BlablaGreg Driver.
    #2157
    wrmuuxwrmuux
    Participant

    @absoluticrous

    I got the exact same setup, Kinect One, 2 PS Move, same CPU, 16gb ram and my controllers got no delay (but the buttons don’t work, but that another thing), how did u manage to get ur cpu-usage that low? when i start riftcat (1.5 because 2.0 causes my phone in gear vr to a blackscreen),ps move, driver4vr my cpu is at about 90% and GPU also without even playing (i got a gtx970).

Viewing 25 posts - 1 through 25 (of 25 total)
  • You must be logged in to reply to this topic.