Release 3.10.2 – Nolo tracker orientation fix, Wii yaw from Plus

Homepage Forums Announcements Release 3.10.2 – Nolo tracker orientation fix, Wii yaw from Plus

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #3315
    Bla BlablaGreg Driver
    Keymaster

    In this release:
    – fix orientation of nolo devices when used as trackers
    – use Wii Plus extension data to calculate Yaw but only when Kinect will detect Yaw more then 30 degree. What will allow make bigger angle and drift is recalibrated when you point again directly to Kinect.

    #3322
    DesunyanDesunyan
    Participant

    I can confirm that both rotational and positional tracking with Nolo VR finally works and does it really well! There is still slight rotational drifting issue when tracker can randomly start rotating from initial orientation. It happens very randomly – sometimes after 20 seconds and sometimes after 20 minutes. Currently in VRChat I fix this by changing avatar and recalibrating. Probably this is just Nolo issue but would be cool if there is a way to reset orientation of trackers to initial by pressing some key combination on controllers.

    #3323
    Bla BlablaGreg Driver
    Keymaster

    i noticed only tracker drifts.
    you can fix this by double press of system button. or change avatar cause avatar takes relative values.
    i also think it happens only on start but not sure.

    #3459
    aymeric aymericpuluch
    Participant

    Hey, i’m trying this version with the leap motion kinect 360 and joy cons. The joy cons are detecting the position correctly but I can’t get any buttons to work. Any clue ?

    For the record if it can help for anything, I needed to assign the right joy-con to the left controller and the left joycon to the right controller. Everytime I start driver4vr, the controllers are reversed 180° (but with the reset yaw button everything get back on tracks).

    #3468
    PodPod
    Participant

    @Greg,

    When using PsMoves, I find that pretty much all the face buttons (circle, triangle, square, X) seem to be unable to be held properly.

    In Steam Home for instance if I hold down the button for the tutorial/guide window then it will flicker on and off every 0.5 seconds or so.
    I’ve gone into the preview on driver4VR and its correctly reporting that the button is held down. As does the PSMoveService’s button test page.
    In Arazona Sunshine it means I instantly teleport around etc.

    Are you perhaps reporting the buttons as UP on any frames where the skeleton/LED cant be found or something similar? Or perhaps is that SteamVR’s doing on any frame it doesn’t get input data? (If so you could transmit the last known data?)

    This doesn’t seem to occur for the trigger or action/touchpad button.

    It makes using a lot of applications very difficult.

    Cheers

    Pod

    • This reply was modified 2 years, 9 months ago by PodPod.
    • This reply was modified 2 years, 9 months ago by PodPod.
    #3513
    Bla BlablaGreg Driver
    Keymaster

    i will add extra logs to see what problem is.

    #3839
    PodPod
    Participant

    @greg did you get anywhere with the flickering button issue? Were you able to replicate it?

    #3840
    Bla BlablaGreg Driver
    Keymaster

    yes. i tested but did not notice anything.
    by flicker you mean press and unpress. yes ?

    #3847
    PodPod
    Participant

    @greg
    Yes but only in game. The d4vr config page and psmoves own config page was correctly reporting the buttons as held. It was only in game/steamvr home that I had the issue.

    In steamvr home if you hold the button that brings up the tutorial pane it would turn on and off repeatedly. Did that not happen for you?
    In arazona sunshine if I held the teleport button it would rapidly teleport me forward (it’s supposed to wait until you release the button)

    Could this be an issue with psmove service itself?

    #3897
    PodPod
    Participant

    @greg

    (Btw, all of this was on 3.10.6)

    I did a bit more testing today.
    It would seem that the only button that exhibits this behaviour is the Menu button (Square on the right psmove).

    Cheers

    Pod

    P.s There are other oddities with Psmove integration though. The config screen says that both X and Circle are assigned to Grip. But for me Circle is actually assigned to Menu as well as Square. (all flipped on the left psmove obviously).
    Also, theres still settings on the config screen that refuse to save. I now cant save the touchpad option, it always sets itself back to single press
    Finally, sometimes the vive wands in VR do some odd things. Sometimes they disappear completely but only when I launch a game. Today, I had it where everytime I pressed the trigger the vive wand vanished.

    P.s.s Have you considered a bug wall/database that we could view and see progress etc. You only replied here after I bumped it so I’d never have known you’d already looked at it and needed more info. Having a public facing progress system would help us report whats needed etc.

    #3954
    Bla BlablaGreg Driver
    Keymaster

    can you check if in this build buttons work properly? it should also save configuration settings each time.

    #3997
    PodPod
    Participant

    @greg

    Hi Greg!
    Hooray! Thats fixed the menu button issue. Thanks for that

    Sadly I can confirm that the saving issue is still there. Rotation angle and touchpad delay both save ok but Reverse rotation will only save if one of the other settings is also changed.
    SteamVR Touchpad press doesnt save no matter what I change. Its always set to the single click setting.

    Sadly Theres a bigger issue in this build. The rotation teleport position bug is back. As soon as I use the buttons to rotate me 90 degrees I’m teleported out of the steamVR house (into a wall this time). Any further rotations happen at that new spot.
    Unlike last time it doesnt appear as if the room setup is being corrupted/wiped. It simply seems to think I’m in that world spot.

    My settings
    Touchpad press – Single click
    angle – 90 Degrees
    Rotation – Your location
    Reverse – Yes
    Touchpad delay – Yes

    Cheers

    Paul

    #4062
    PodPod
    Participant

    @greg

    Any news on a fix for the broken rotation?

    Cheers

    Pod

    #4087
    Bla BlablaGreg Driver
    Keymaster

    yes. released just now 🙂

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.