Quick 180 flip?

Homepage Forums General Quick 180 flip?

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #2907
    PodPod
    Participant

    Hey everyone.

    Does anyone know if there’s a way to flip 180 (or 90) by pressing a button on a controller?
    I’m using a 360 kinect with a ps move so I can only use it when facing forward but most of the decent games are all around you I’ve found (please recommend some ones that aren’t!).
    I’ve installed advanced vr which allows me to either flip 180 or set a random rotation of the play space but you (as far as I can tell) have to do this via menus which is frustrating and takes you out of the experiance.

    I can see that there’s some kind of option at the bottom of driver 4 vr that talks about moving but theres no instructions on what it does?

    Anyway. Any help or advice appreciated.

    Pod

    #2927
    PodPod
    Participant

    Ah ha. Just found the rotate option on the psmove button configuration screen. Have set it to rotate 90 degrees on each press. HOWEVER, this also rotates the chaperone making it useless in room scale setups
    Can it be tweaked to not rotate the chaperone? AdvancedVR has that option on a tick box.

    Cheers

    Paul

    #2938
    Bla BlablaGreg Driver
    Keymaster

    i will investigate. it should not work this way.
    can you tell if you did room calibration in same vr session ? i have feeling that it might have relation.

    #2943
    PodPod
    Participant

    I had been using chaperone tweak to build my chaperone space. I can’t run valves roomsetup as my playspace is too small.
    I can try again tonight to see if a brand new session does the same thing.

    #2952
    Bla BlablaGreg Driver
    Keymaster

    if you could see if error happens on ‘clean’ steamvr run and by that I mean that no configuration changes are done.

    #2975
    PodPod
    Participant

    Sadly I can confirm that it does rotate the chaperone on a clean run. I booted my pc. ran riftcat and then launched steamvr.
    Pressing Triangle on the right psmove rotated the world 90 degrees but kept the chaperone in the same game space (and thus also rotated 90 degrees to where it originally was).

    Hopefully its an easy fix 😀

    Cheers

    Paul

    #2979
    JonnyJonny
    Participant

    Could you also add the flip function to the old configure buttons menu? Cheers.

    #2982
    Bla BlablaGreg Driver
    Keymaster

    @Pod so you would like that it rotate you around your location ? right ?


    @Jonny
    can you clarify ?

    #2987
    PodPod
    Participant

    I’d like it to stay in the same real world location and rotation.
    As you might imagine. Some chaperones are oddly shaped. Mine is more of a trapezoid and it’s also off centre.
    At the moment since it rotates with the game world it no longer matches my furniture as soon as I use the psmove to turn. There’s a real danger that I’ll now walk into a wall!!

    I’m not sure I can think of any situation where you’d want the current behaviour. Cheers

    Paul

    #2988
    Bla BlablaGreg Driver
    Keymaster

    yes. i know that. only problem that as you keep on rotating, you might run away from playspace area. i will add extra parameter to make rotation as you need.

    #2989
    Bla BlablaGreg Driver
    Keymaster

    can you check this build? you will find in ps move settings ability to change center of rotation.

    #2990
    PodPod
    Participant

    Cool. Will try tonight. Cheers!

    #2991
    PodPod
    Participant

    Oh. Just understood what you were asking. Yes. It should still rotate the world around my position.

    #2992
    Bla BlablaGreg Driver
    Keymaster

    yes. it should work this way in build.

    #3011
    PodPod
    Participant

    Hi Greg,

    Thanks for posting an update so soon however I was unable to test it as when you close the psmove configuration window the setting reverts back to “chaperone center” every time. (I did test it in game anyway but its the same behaviour as before)

    Also, (I’ll post this in the joycon one as well) I tried a joy con with this build. I paired my left joycon before I started everything up and it correctly identified it was my left joycon in the driver4vr controller device manager. However the configure button did nothing. Nevertheless I assigned it to the left hand and in game it both failed to rotate my left hand/wand and none of the buttons did anything.

    I should be able to do more testing tomorrow if you’ve got another build or different instructions. Otherwise friday night.

    Cheers

    Paul

    • This reply was modified 2 years, 10 months ago by PodPod.
    #3056
    PodPod
    Participant

    Hi Greg,

    So I was able to get the setting to save by either changing a second setting or closing the window using the top left corner instead of the x in the top right. Not sure which as I did both.

    But, while it now rotates around the correct point it unfortunately still rotates the chaperone which needs to stay in the same real world space (I.e remain in the same location and rotation to the player)
    Also. I’m pressing triangle on the right ps move and it’s rotating the game world to the right and not the player. For me at least that’s backwards and it should rotate the player instead.

    I’ve made an image to explain. I’ll upload after I’ve had my dinner.

    Cheers

    Paul

    #3058
    PodPod
    Participant

    Here you go. Hopefully that makes sense. As I’ve marked. What I’m after is what AdvancedVR does (but sadly only through menus)

    Cheers

    Paul

    Attachments:
    You must be logged in to view attached files.
    #3145
    PodPod
    Participant

    Did that makes sense?

Viewing 18 posts - 1 through 18 (of 18 total)
  • You must be logged in to reply to this topic.