Mapping for rotation

Homepage Forums New feature Mapping for rotation

Viewing 34 posts - 1 through 34 (of 34 total)
  • Author
    Posts
  • #276
    JonnyJonny
    Participant

    Hi Greg,

    I would like to remap rotation to the analog stick of the psnavi, is that possible? The navi is working fine paired with my psmove with psmove service. But there isn’t a way to map rotation to the touchpad in Driver4VR.

    Thanks, I like what you have done with Driver4VR, it is very cool.

    #282
    Bla BlablaGreg Driver
    Keymaster

    Johny,
    can you tell how did you make PS Navi working? other people have problems setting it up.

    you would like to map virtual rotation to ps navi. yes?

    Greg

    #302
    JonnyJonny
    Participant

    I just followed the Daley Tech guide here .

    I have only tried it wired to usb, using scptoolkit, because I still need a 2nd bluetooth dongle. I have only tried a couple of games and managed to get basic functionality, but the buttons were in the wrong places, just need to change the steamvrsettings config I think.

    And yes, virtual rotation to navi, but since scptoolkit uses xinput, I guess rotation in driver4vr would just need to be mapped to the xbox controller?

    • This reply was modified 3 years, 3 months ago by JonnyJonny.
    #304
    JonnyJonny
    Participant

    Actually I was wrong. The navi controller does work for me with SteamVR and PsMove Service. It is detected by psmove service without a problem, but I can’t get xbox emulation working properly. No idea why.

    #306
    JonnyJonny
    Participant

    Ok I also now have xbox input working properly. Just needed a reinstall.

    #706
    Bla BlablaGreg Driver
    Keymaster

    hi.
    wehat did you reinstall?

    #723
    JonnyJonny
    Participant

    The problem I was having then was only in usb mode. After I got a bluetooth dongle and reinstalled scptoolkit 1.6 with the bluetooth dongle, it works fine for ordinary non vr games, and steam. Only issue now is mapping not saving properly in driver4vr.

    #727
    Bla BlablaGreg Driver
    Keymaster

    you mean it is not saving properly when you restart steamvr. yes?
    if you map it properly during one steamvr session it works fine?

    #732
    JonnyJonny
    Participant

    Exactly, yeah.

    #738
    Bla BlablaGreg Driver
    Keymaster

    i tried different controllers and also different pc and could not reproduce issue. i will send you later this week test version with some extra logs.

    #743
    JonnyJonny
    Participant

    Ok, thanks.

    #744
    Bla BlablaGreg Driver
    Keymaster

    can u try this release and send me back logs ?
    please start steamvr 3 times so I can see what happens each time.

    How to send diagnostic logs

    https://drive.google.com/file/d/0B97CTM_n2lgMN0JibVotdzAwSzg/view?usp=sharing

    #787
    JonnyJonny
    Participant

    Ok, here it is. Tried 3 times.
    Thanks.

    Attachments:
    You must be logged in to view attached files.
    #798
    Bla BlablaGreg Driver
    Keymaster

    hello. i can see you only started once steam in this log. can u make one more test please?

    Sun Oct 15 2017 20:19:00.972 – driver4vr: Initializing Driver4VR version: 2.1.0.0

    #801
    JonnyJonny
    Participant

    Hi,

    I started steamvr three times, but each time it deletes the log. I copied new 2 logs, and will post them here. I noticed I have the psmove driver still installed. Will try removing it and see what happens.

    Thanks.

    Attachments:
    You must be logged in to view attached files.
    #803
    JonnyJonny
    Participant

    The next one.

    Attachments:
    You must be logged in to view attached files.
    #814
    Bla BlablaGreg Driver
    Keymaster

    i can see only 2 devices which is fine… can you send me once more steamvr.vrsettings ? if you don’t mind doing once more configuration of one button.

    Wed Oct 18 2017 20:41:56.614 – driver4vr: Enumerating device: {2C8CBB70-132F-11E6-800C-444553540000}
    Wed Oct 18 2017 20:41:56.647 – driver4vr: Enumerating device: {DFC499B0-A226-11E7-8002-444553540000}

    #826
    JonnyJonny
    Participant

    I have decided to give up on the navi for now, and bought a magicsee r1 to try instead. And it works very well. Not as sensitive as the navi but tracks better, and saves mapping every time. So I won’t need to get the navi working any time soon now. It is fine as a spare WASD controller.

    I have attached the settings file anyway in case it helps you solve this problem (if it isn’t just me) and get navis working in general. I think the navi controller is all the ones with the 000000000… ids.

    #827
    JonnyJonny
    Participant

    Try again.

    #828
    JonnyJonny
    Participant

    And again…

    #829
    JonnyJonny
    Participant

    Mmm… having trouble uploading the file…

    #838
    Bla BlablaGreg Driver
    Keymaster

    i will try upload file.

    also I think I found potential problem. i will share test release and i wonder if you would mind testing it.

    Greg

    Attachments:
    You must be logged in to view attached files.
    #840
    Bla BlablaGreg Driver
    Keymaster

    can you change extension of txt ?

    #842
    JonnyJonny
    Participant

    Here goes.

    Attachments:
    You must be logged in to view attached files.
    #844
    JonnyJonny
    Participant

    Sure, I don’t mind testing it. Cheers.

    #856
    Bla BlablaGreg Driver
    Keymaster

    Hi,
    can you please check if that version works with mapping between steamvr sessions?

    https://drive.google.com/file/d/0B97CTM_n2lgMcjJod1J1dHIyNmc/view?usp=sharing

    #860
    JonnyJonny
    Participant

    Hi,

    I tried but it gives an immediate crash on a clean installation. I deleted all the driver4vr folders before installing.

    #862
    Bla BlablaGreg Driver
    Keymaster

    canu please try this one ? it should run smoothly. can u send me also vrserver log and steamvr.vrsettings config please? pllease also try to run steam 2-3 times.
    https://drive.google.com/file/d/0B97CTM_n2lgMX01GQkVUX2ZSZWs/view?usp=sharing

    #864
    AndecAndec
    Participant

    are you using a xbox controller to move in vr?
    i’d really like to do that with my 3dconnexion spacemouse.
    could you give me a few pointer if this is the case?

    #865
    JonnyJonny
    Participant

    Hi Greg,

    I tried the new version, and… it works! Excellent work. It didn’t remember the controller the first time I tried but I remapped and tried a second time, and now it seems the navi buttons have been remembered. It shows up as “W” in the device ID.

    I will send the logs anyway.

    Cheers.

    I will let you know if I notice anything.

    Attachments:
    You must be logged in to view attached files.
    #882
    JonnyJonny
    Participant

    I noticed Psmoves also work well. Not sure if they did before but once paired in psmove service they don’t need psmove service anymore, and mapping is fine. That’s great.

    One more thing though, is it possible to get the psnavi trigger working?

    And I posted this on another thread, but is controller vibration possible? Cheers.

    #899
    Bla BlablaGreg Driver
    Keymaster

    great it is working.
    let’s talk about vibration in next year as I have some things to implement right now. ok?
    cheers.

    #905
    JonnyJonny
    Participant

    Sure, thanks.

    #37297
    Duoc NovacoDuoc Pham Novaco
    Participant

    Hi all, have a great day.

Viewing 34 posts - 1 through 34 (of 34 total)
  • You must be logged in to reply to this topic.