Leap Motion troubles

Homepage Forums How-to and troubleshooting Leap Motion troubles

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #590
    JonnyJonny
    Participant

    Hi Greg,

    I just got my leap motion (using a Pimax), and generally I am impressed.
    I just have a couple of issues.
    The main one is that my controllers appear about 10cm closer to the center than my hands are. In the leap motion demos the tracking is perfect, but in steamvr the controllers are way too close together. Is there a way to move them horizontally?

    The second is to do with bluetooth controllers. I have a couple of controllers that seem to map fine in driver4vr, but then in steamvr they do nothing. Any ideas?

    Thanks,

    Jonny

    #591
    bgamer86bgamer86
    Participant

    I am having the same problem with leap motion and bluetooth controller working in steamvr. It all worked great for me but after the update it stopped working.

    #598
    Bla BlablaGreg Driver
    Keymaster

    hi.
    the controllers are 10 cm closer to allow you play games that require two hand aiming like longbow in the labs.

    are u saying that controller mapping does not work after update?

    #600
    JonnyJonny
    Participant

    Makes sense. Is there a way to change it temporarily? Like when not playing games that don’t require the bow action, itd be nice if the hands/controllers were aligned.

    #601
    JonnyJonny
    Participant

    I mapped one controller before the update, and that still works, but after the update a different controller refuses to work in steam vr. psmove also.

    #603
    bgamer86bgamer86
    Participant

    Yes after the update controller mapping stopped working.

    #604
    evertecevertec
    Participant

    I’m also having issues. I just bought this driver so I’ve never had it working, when I add the controller and assign the buttons it doesn’t do anything once in steamVR. Anyone have an older version they could share?

    #605
    Bla BlablaGreg Driver
    Keymaster

    okey. i need double check. sorry but I can provide update only by Monday…
    so I guess if someone has it working then it is working as well.

    greg

    #607
    JediahJediah
    Participant

    I had the issue before and after the update with one controller I had bought off amazon. I had grabber two different models that looked similar to Gregs. One worked the other did not. The difference was in the drivers windows 10 would load. It seems with the bluetooth controller that worked window was loading it as a keyboard. the one that wouldnt work in steamvr would be loaded by windows as a 2 axis and X button controller. You can view how windows has it loaded using the windows game controller panel. The icons in the attached devices screen is different as well. The one that works will have a keyboard an mouse icon and the one that doesnt work will only have a keyboard icon. I was able to find a replacement at my local Walmart that is loaded by Windows 10 correctly. The controller that works from Walmart is the Merkury Innovations EVO VR Controller https://www.walmart.com/ip/Merkury-Innovations-EVO-VR-Controller/176096211
    they have worked great in the setup I am using with a Kinect 360 and leap motion. I am keeping the Kinect head tracking enabled and body tracking. I am using a correction angle of -180 to avoid the 100 foot head issue. I am able to realign using the move function and rotate in steam vr. I also have the issue where the leap reverses you when you try to reset in Riftcat. I either turn around and reset making my point correct when i turn back around or I use the reset in virtual desktop which always make everything correct. This Driver is great Greg. Some of the issues are issues that I have had with various set ups long before I ever tried your driver4vr. Ssome are Steam vr issues and some are Riftcat. All in all your driver has allowed me to try most everything I have downloaded for steamvr. From old stuff like The lab to the brand new Duck Season. They are not all perfect all the time but definitely playable with a little ingenuity and tinkering. I hope this info is helpful. I am in a bit of a rush as it is my day off and I just downloaded 25 of the better free VR games to try from Steam. On to the games. Have a great day everyone.

    #610
    Bla BlablaGreg Driver
    Keymaster
    #612
    JonnyJonny
    Participant

    I just tried it, briefly, and it looks good. I mapped the controls in driver4vr, to my vrcase controller, then in steamvr the buttons worked. The controller cut out but I think that was the controller’s fault. Thanks!

    Edit: Yeah it was the controllers fault. It works great.

    • This reply was modified 3 years, 2 months ago by JonnyJonny.
    #614
    JonnyJonny
    Participant

    Ok, I spoke a little too soon. I noticed that the horizontal axis won’t map properly. All other buttons I have tried work. Vertical axis works fine. In driver4vr the axis is detected and mapped, but it won’t show up in SteamVR.

    #615
    Bla BlablaGreg Driver
    Keymaster
    #616
    JonnyJonny
    Participant

    Ok, that seems to have fixed it. Will let you know if I notice anything else.
    Thanks, Greg.

    #619
    JediahJediah
    Participant

    I did the testing on the first beta you had posted and everything worked fine. I had to use the invert axis to get those to emulate correctly. I have to run room set up after every couple of games but that is not so abnormal with rift cat and leap. I also have to manually shut a few games off here and there and restart riftcat and steam vr. Again not that abnormal in my experience with cheap options to try out VR. I am happy to beta test for you whenever I have time. Thanks for all the effort Greg.

    #1685
    darkagnadarkagna
    Participant

    im having this exact issue, and the steam controller model issue…. can someone explain to me how to fix this, and what these “releases” are, the downloads are gone.

    #1691
    Bla BlablaGreg Driver
    Keymaster

    hi. the type of controller shown is not related. it is just image.
    it is ok as long as all is working fine.
    the problems on this thread they were related to proper way of mapping buttons/axis to steamvr.
    i will fix this in one of incoming releases.

    #1765
    darkagnadarkagna
    Participant

    the new update made it possible to map all the buttons, but my controller wont work ingame….

    this is my config
    {
    “driver4vr” : {
    ” Axis 1″ : “Vive Controller MV HTC LHR-00000000 0 0 40 0″,
    ” Axis 2″ : “Vive Controller MV HTC LHR-00000000 1 0 40 0″,
    ” Axis 3″ : “Vive Controller MV HTC LHR-00000000 0 0 40 0″,
    ” Axis 4″ : “Vive Controller MV HTC LHR-00000000 1 0 40 0″,
    ” Button 1″ : “Vive Controller MV HTC LHR-00000000 3 0 40 0″,
    ” Button 10″ : “Vive Controller MV HTC LHR-00000000 4 0 40 0″,
    ” Button 13″ : “Vive Controller MV HTC LHR-00000000 3 0 40 0″,
    ” Button 5″ : “Vive Controller MV HTC LHR-00000000 2 0 40 0″,
    ” Button 6″ : “Vive Controller MV HTC LHR-00000000 7 0 40 0″,
    ” Button 7″ : “Vive Controller MV HTC LHR-00000000 6 0 40 0″,
    ” Button 9″ : “Vive Controller MV HTC LHR-00000000 4 0 40 0”,
    “D4Tracker-d4vr_left” : “0 360 0 100 80 100 x”,
    “D4Tracker-d4vr_right” : “0 360 0 100 80 100 x”,
    “D4Tracker-trackerHips” : “0 360 0 100 80 100 x”,
    “D4Tracker-trackerHmd” : “0 360 0 100 80 100 x”,
    “D4Tracker-trackerLeftArm” : “0 360 0 100 80 100 x”,
    “D4Tracker-trackerLeftFoot” : “0 360 0 100 80 100 x”,
    “D4Tracker-trackerRightArm” : “0 360 0 100 80 100 x”,
    “D4Tracker-trackerRightFoot” : “0 360 0 100 80 100 x”,
    “cameraExposure” : 1,
    “controllerOffset” : 20,
    “controllers” : “5,6”,
    “d4vr_left” : “2 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0”,
    “d4vr_right” : “0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0”,
    “enableKinectTrackers” : true,
    “forceViveDriverName” : true,
    “handTrackingSource” : 3
    https://puu.sh/yR6rC/eb5a0f01dd.png

    #1767
    darkagnadarkagna
    Participant

    i got my config to look like this
    “{D902AB80-9443-11E7-8001-444553540000} Axis 1” : “d4vr_right 1 1 40 0”,
    “{D902AB80-9443-11E7-8001-444553540000} Axis 2” : “d4vr_right 0 0 40 0”,
    “{D902AB80-9443-11E7-8001-444553540000} Axis 3” : “d4vr_right 1 1 40 0”,
    “{D902AB80-9443-11E7-8001-444553540000} Axis 4” : “d4vr_right 0 0 40 0”,
    “{D902AB80-9443-11E7-8001-444553540000} Axis 5” : “d4vr_left -2 0 40 0”,
    “{D902AB80-9443-11E7-8001-444553540000} Axis 7” : “d4vr_left 3 0 40 0”,
    “{D902AB80-9443-11E7-8001-444553540000} Button 10” : “d4vr_right 6 0 40 0”,
    “{D902AB80-9443-11E7-8001-444553540000} Button 5” : “d4vr_right 7 0 40 0”,
    “{D902AB80-9443-11E7-8001-444553540000} Button 7” : “d4vr_right 2 0 40 0”,
    “{D902AB80-9443-11E7-8001-444553540000} Button 8” : “d4vr_right 3 0 40 0”,
    “{D902AB80-9443-11E7-8001-444553540000} Button 9” : “d4vr_right 6 0 40 0”
    disabling windows power management in steam vr settings seemed to give my controller a proper id. now my issue is i only see vive controllers in steam home even with vive mode on, steam controllers in everything else, and every mapped button opens the vr dashboard….. disabling the dashboard makes them do nothing.

Viewing 19 posts - 1 through 19 (of 19 total)
  • You must be logged in to reply to this topic.