I'm almost up and running but position is off

Homepage Forums How-to and troubleshooting I'm almost up and running but position is off

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #4181
    TDodge7TDodge7
    Participant

    Hi, I’ve been trying to get full body tracking going in VRchat with my Samsung Odyssey/Kinect One/Driver4VR and I’ve almost got it, my only problem is the positioning.

    On the main Driver4VR window I have headset and hand controls off, and skeleton on and then I go into calibration mode. If I select hips or feet out of the choices and then calibrate them the 3 trackers appear but the hip is at eye level, and the feet are near my waist, also the trackers are 5-8 feet away from me (they track well though). If I choose to calibrate the headset instead of the individual feet & hip then I get a much better position with the hip at about crotch level and the feet near the shins/knees. However no matter how I calibrate it the trackers are always a few feet away from me, and the feet are never on the ground.

    When I go into VRchat it spawns me in T pose but the trackers are 5-8 feet away from me. Because I have the joysticks enabled on my Odyssey I’m able to move over to the trackers, and then physically walk over to my avatar and then attach it. Though all the avatars want to squat down because of the incorrectly placed trackers, I can adjust height to get the avatar to stand up straight but by that point my view angle is far above the head of my avatar. The tracking is pretty good though as long as I face the Kinect.

    What can I do to fix this? I’ve tried calibrating a million times and I’ve tried using the floor height fix in advanced settings and it didn’t change anything. Everything is working it’s just in the wrong spot.

    #4194
    TDodge7TDodge7
    Participant

    Could room setup have anything to do with it? I’ve only traced my boundary in the Microsoft mixed reality portal and not in Steam VR. But my traced boundary shows up in Steam VR just fine and matches up with the floor so I never bothered. I’m so close to getting this working, are you out there Greg?

    #4202
    Bla BlablaGreg Driver
    Keymaster

    hi.
    don’t change any selection in calibration window. just go on with what is there and let me know.

    #4232
    TDodge7TDodge7
    Participant

    That’s what I’ve been doing, in the main window the only trackers turned on is the body, it’s set to skeleton. Then when you click calibrate the first item in the drop down list is HMD and that’s the one I calibrate.

    I just tried it again but this time I put the kinect a little farther away and that seemed to help some. This time it looked like it was putting the feet on the floor, the hips were low but not by a whole lot. It still didn’t place the trackers exactly where I was standing but they weren’t as far away. In VRchat though I had to move around with the joysticks to get to the orbs and then physically walk to my avatar even though in SteamVR the trackers were almost where I was.

    I also notice sometimes in calibration that if I move far enough in one direction a second smaller skeleton will move into frame, why does it do that?

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.