Could not register driver

Homepage Forums How-to and troubleshooting Could not register driver

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1027
    FreelancerB10FreelancerB10
    Participant

    While trying to install Driver4VR, once the setup is done and the installer runs, I only get a message that states: “Could not register driver:. The system cannot find the file specified.”

    I have tried installing it in multiple places including on all of my drives, in the default steam folders, and just the default install location in program files (x86) but it does not seem to fix it like it did for the other user in this forum with the same issue.

    I’m trying to use a Kinect 360, I have SDK v1.8 installed and I see my kinect in my device manager.

    #1053
    Bla BlablaGreg Driver
    Keymaster

    hi, can you tell me where you have SteamVR installed ?

    manual way is to register driver manually

    in folder:
    C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64

    you need execute

    vrpathreg adddriver ‘path to driver4vr driver folder’

    in my case it is

    C:\Program Files (x86)\Driver4VR\lib\drivers\driver4vr

    let me know if that works.

    if you don’t mind telling me where your installation is I will try to fix problem.

    #1123
    AzuthAzuth
    Participant

    I’m not familiar with executing from the command line, but am I doing something wrong? I go to windows -> Run and type the following:

    F:\Program Files (x86)\Steam\SteamApps\common\OpenVR\bin\win64\vrpathreg.exe adddriver ‘C:\Program Files (x86)\Driver4VR\lib\drivers\driver4vr’

    but I still get the same error.

    Is there a problem with my syntax?

    #1134
    Bla BlablaGreg Driver
    Keymaster

    first change folder to:
    F:\Program Files (x86)\Steam\SteamApps\common\OpenVR\bin\win64\

    and run command direcly from there.

    perhaps you would agree to do some check so I can improve my installer?

    #2325
    DAATNDAATN
    Participant

    Greg I am having the same issue as above and have tried this from the command line with no success. Any advice?

    #2332
    Bla BlablaGreg Driver
    Keymaster

    so what happens duringg installation ?
    then you tried commands and also don’t work? what exactly don’t work. you don’t see icon and app does not start ??

    #2720
    PodPod
    Participant

    I had this. I have steam installed on c in the usual place but my vr install is in a separate steam folder on my d drive.
    It might be possible to query steam for all its install folders and try them in turn? Or give us an option to specify a folder?

    #2728
    PodPod
    Participant

    FYI.i moved steam vr to my c drive and then it all worked. I should point out that I tried the cmd line steps outlined above and they also failed while steam vr was on d

    #2770
    Bla BlablaGreg Driver
    Keymaster

    glad it works but… it should find steamvr location and if not, it should prompt you to select folder….
    do you remember what was the message or error?

    #2919
    manny2709manny2709
    Participant

    I am baffled I have tried everything I know. And in the forums and its just not working. Tried the command to add the driver manually and moved steamvr to the default DIR. Still nothing……

    #2946
    Bla BlablaGreg Driver
    Keymaster

    can you start driver window manually from program files and send me logs as described here?

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.