This is more likely your models not being in similar proportions to your own body. I have the same problem, i have 30ish avatars uploaded and all of them have really long legs, and I don’t. So the leg bones don’t match up well at all.

Hip bone placement in the body is important as well, i’ve found that MMD models in particular place the bottom of the hip bone directly in line with the top of the leg bones and in a lot of cases it cause the the hip to tilt either forward or backwards.
To alleviate that you can raise the position of the hip bone in blender.

One thing i found to help a lot with the proportion problem (after spending hours editing my models) I tried adjusting the calibration settings. in the settings you can raise/lower the hip bone artificially and the same with the feet. So what worked best for me was finding the correct height in game then switching to the avatar i want. line up the balls and hands as best I can. then after that go into the driver4vr calibration settings and adjust the feet and hips to match where they should normally be on your model. For feet use a negative value to lower the foot controllers and hips use a positive value to raise the hip controller.

It takes some fiddling but its way easier to do it like that then to have to re do all my models.

Hope that helps, hit me up in the vrchat discord if you need more help.

Also if you want to test without adjusting the heights of the controllers use the default x-bot or y-bot avatars, they have humanlike proportions and worked pretty well for me, the Y bot was still a little tall but usable.